Home >> php >> php 5.3:connection failed:SQLSTATE[HY000] [2000] mysqlnd cannot connect to MySQL 4.1+ using old authentication

php 5.3:connection failed:SQLSTATE[HY000] [2000] mysqlnd cannot connect to MySQL 4.1+ using old authentication

最近开发环境升级到了 php 5.3.2, 链接 remote mysql 却发生了错误:
(原文链接 http://ddbiz.com/?p=181)
connection failed:SQLSTATE[HY000] [2000] mysqlnd cannot connect to MySQL 4.1+ using old authentication remote 的 mysql db my.cnf:

[mysqld]

datadir=/var/lib/mysql

socket=/var/lib/mysql/mysql.sock

# Default to using old password format for compatibility with mysql 3.x

# clients (those using the mysqlclient10 compatibility package).

old_passwords=1

是采用兼容格式的密码,而 php5.3的php_mysql; php_pdo_mysql 采用的是增强的密码,所以导致两者不匹配,最方便的方式还是更新db的设置,取消 old_passwords
然后在 mysql.mysql.user,更新所有用户的密码, 如:
update user set password=PASSWORD(‘new password’) where user=’this user’;
flush privileges;
即可
不过更新my.cnf 需要重新启动 mysql ,对于应用中的服务器,不是必要就千万别更新php客户端了,哈哈

(原文链接 http://ddbiz.com/?p=181)

留言/有话要说

Copyright © 2012 Dimensions Data Business. All rights reserved.
server process 4.664 seconds.
WP-Backgrounds Lite by InoPlugs Web Design and Juwelier Schönmann 1010 Wien